Forum: Installation

Post: Faild to build the latest VoltDB community edition with "AttributeError: BuildContext instance has no attribute 'CXX_VERSION_FLAG'"

Faild to build the latest VoltDB community edition with "AttributeError: BuildContext instance has no attribute 'CXX_VERSION_FLAG'"
nntp
Mar 16, 2016
OS: CentOS Linux release 7.2.1511 (Core)

EPEL:epel-release-7-5.noarch

JAVA:
openjdk version "1.8.0_71"
OpenJDK Runtime Environment (build 1.8.0_71-b15)
OpenJDK 64-Bit Server VM (build 25.71-b15, mixed mode)

ANT:
Apache Ant(TM) version 1.9.2 compiled on June 10 2014

Compiler:

gcc-c++-4.8.5-4.el7.x86_64

PYTHON:
Python 2.7.5

CMAKE:
cmake version 2.8.11

================
When download the latest codes from github and run "ant" it stopped and prompted:

buildinfo:
[exec] Version: 6.2 voltdb-6.1-108-ga796cf7

ee_buildmakefile:
[exec] Traceback (most recent call last):
[exec] File "build.py", line 99, in <module>
[exec] CTX.CPPFLAGS += " " + CTX.CXX_VERSION_FLAG
[exec] AttributeError: BuildContext instance has no attribute 'CXX_VERSION_FLAG'
[exec] Cannot find compiler version by running "g++"

BUILD FAILED
/root/voltdb/build.xml:1565: exec returned: 1

===============================
g++ are all on the searching PATH.

[root@centos_head voltdb]# which g++
/usr/lib64/ccache/g++
[root@centos_head voltdb]#

Thanks and any clue?
pzhao
Mar 16, 2016
nntp,
I've just successfully completed building the latest voltdb, v6.2, on a fresh centos machine.
Try installing these VoltDB dependencies:
sudo yum -y install ant ant-nodeps ant-junit ant-scripts ant-javadoc ant-trax gcc gcc-c++ python valgrind ntp python26 git-all python-httplib2 python-setuptools python-devel ccache cmake bzip2

UPDATE: In our github wiki, we have instructions on setting up your VoltDB environment: https://github.com/VoltDB/voltdb/wiki/Building-VoltDB

Another issue I ran into was a build failure that looked similar to something like this:
[exec] g++: internal compiler error: Killed (program cc1plus)
[exec] Please submit a full bug report,
[exec] make: Leaving directory `/home/pzhao/workspace/voltdb/obj/release'
[exec] Building with C++11
[exec] Compiler: gcc 4.8.5
[exec] OpenSSL: version 1.0.2d, config linux-x86_64:gcc -fpic
[exec]
[exec] with preprocessed source if appropriate.
[exec] See <http://bugzilla.redhat.com/bugzilla> for instructions.
[exec] make: *** [objects/indexes/tableindexfactory.o] Error 4

This was solved by providing more RAM, i.e. 4GB to my virtual machine. I previously had <1GB configured.
Let me know if this helps.
Peter Zhao