Forum: News & Announcements

Post: VoltDB and Java Version 7

VoltDB and Java Version 7
ajgent
Nov 23, 2011
Hi,

There are known issues with the use of the current version of VoltDB on Java 7, due to changes in the Java interfaces. For example, under Java 7 the VoltDB sample applications may generate the following exception:

Exception: java.util.FormatFlagsConversionMismatchException

We want to remind our community that the current software requirements for VoltDB are Java 6, update 20 or later. VoltDB has not been validated with Java 7 yet. We will be validating Java 7 in the near future.

Thank you,

Andrew
Java 7 now supported
ajgent
Mar 14, 2012
All known issues with Java 7 have been corrected and VoltDB V2.2.2 fully supports the latest Java release.