Forum: Installation

Post: ant built failing

ant built failing
mugua250
Mar 23, 2012
Hi,Guys
Recently i have tested the voltdb, once I obtain the sources, use Ant to build a new distribution kit for the current platform, i got the error message, can you give me some addvice?

[root@server2 voltdb]# ls
bin Click Here to Start.html microbenchmark-config.xml template.classpath voltdb
build.py doc obj tests
buildtools.py examples README third_party
buildtools.pyc lib README.thirdparty tools
build.xml LICENSE src version.txt
[root@server2 voltdb]# ant
Buildfile: build.xml


catalog:

[exec] Warning: --directory (-d) option is undocumented and no-op.
[exec] Use -rf for deleting non-empty dirs
[exec] Warning: --directory (-d) option is undocumented and no-op.
[exec] Use -rf for deleting non-empty dirs

compile_core:

BUILD FAILED
/var/tmp/voltdb/build.xml:765: Could not create task or type of type: depend.
Ant could not find the task or a class this task relies upon.This is common and has a number of causes; the usual
solutions are to read the manual pages then download and
install needed JAR files, or fix the build file:
- You have misspelt 'depend'.
Fix: check your spelling.
- The task needs an external JAR file to execute
and this is not found at the right place in the classpath.
Fix: check the documentation for dependencies.
Fix: declare the task.
- The task is an Ant optional task and the JAR file and/or libraries
implementing the functionality were not found at the time you
yourself built your installation of Ant from the Ant sources.
Fix: Look in the ANT_HOME/lib for the 'ant-' JAR corresponding to the
task and make sure it contains more than merely a META-INF/MANIFEST.MF.
If all it contains is the manifest, then rebuild Ant with the needed
libraries present in ${ant.home}/lib/optional/ , or alternatively,
download a pre-built release version from apache.org
- The build file was written for a later version of Ant
Fix: upgrade to at least the latest release version of Ant
- The task is not an Ant core or optional task
and needs to be declared using .
- You are attempting to use a task defined using
or but have spelt wrong or not
defined it at the point of use

Remember that for JAR files to be visible to Ant tasks implemented
in ANT_HOME/lib, the files must be in the same directory or on the
classpath
Please neither file bug reports on this problem, nor email the
Ant mailing lists, until all of these causes have been explored,
as this is not an Ant bug.
Total time: 1 second
[root@server2 voltdb]#
Ant could not find the task
rbetts
Mar 23, 2012
Ant could not find the task or a class this task relies upon.


Looks like your environment is missing the ant "depends" task. I believe this can often be found the package ant-optional.
Ryan.
More docs
jhugg
Mar 23, 2012
Ant could not find the task or a class this task relies upon.

Looks like your environment is missing the ant "depends" task. I believe this can often be found the package ant-optional.
Ryan.


There's a list of the packages we install here: https://github.com/VoltDB/voltdb/wiki/Building-VoltDB