Forum: Building VoltDB Clients

Post: Unable to initialize module - precompile php extension for v5.4.6

Unable to initialize module - precompile php extension for v5.4.6
lrhache
Dec 4, 2012
Hi,

I have PHP v5.4.6 installed. I downloaded the precompiled php extension for voltdb.
The voltdb extension is copied in the right folder and the extension is loaded in PHP.

Maybe the extension is not built for >v5.4?

Here's the output :

$ php -v
PHP Warning: PHP Startup: voltdb: Unable to initialize module
Module compiled with module API=20090626
PHP compiled with module API=20100525
These options need to match
in Unknown on line 0
PHP 5.4.6-1ubuntu1.1 (cli) (built: Nov 15 2012 01:18:34)
Copyright (c) 1997-2012 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2012 Zend Technologies


Can someone help? Thanks
New PHP Driver
nshi
Dec 5, 2012

I have PHP v5.4.6 installed. I downloaded the precompiled php extension for voltdb.
The voltdb extension is copied in the right folder and the extension is loaded in PHP.

Maybe the extension is not built for >v5.4?


Hi,

The precompiled PHP extension was built for PHP 5.2 or earlier. Please download the new PHP extension which supports PHP 5.3 or later from the following link.

http://voltdb.com/downloads/technologies/client/voltdb-client-php-extension-2.8.tar.gz