Forum: Installation

Post: sqlcmd is not found

sqlcmd is not found
StephenDillon
May 20, 2013
I installed Volt DB Enterprise 3.1 on a server running Ubuntu Server 12.04 LTS and have ensured the Java6 installer was used during the server setup.

The example applications work and I ran them using the associated run.sh script.

If I try to use the sqlcmd utility, via the command line e.g. $ sqlcmd, it is not found. I receive the error "sqlcmd: command not found". In fact, none of the utilities are found.

I do not have the same problem when using the VoltDB 3 demo.


Any ideas?
bballard
May 20, 2013
Hi Stephen,

It is a good idea to add the voltdb-ent-3.1/bin directory to your PATH environment variable. For example, if you installed VoltDB in your home directory, you could use this command:

export PATH=$PATH:$HOME/voltdb-ent-3.1/bin

Then you should be able to use any of the VoltDB command-line tools without having to specify the path to the binary files.

Regards,
Ben
StephenDillon
May 20, 2013
Okay Ben, That worked! I am not sure what my malfunction is with Java class paths. I cannot seem to get them correct but I can with Windows based environment variables. Thanks again.