Forum: Other

Post: Sqlcmd says connection refused when trying to test Helloworld sample

Sqlcmd says connection refused when trying to test Helloworld sample
saju
Jun 11, 2013
Hi,

I have installed VoltDB on a RHEL VM and was following the instructions given in the "Getting started guide". The compilation of helloworld.jar works fine. The create catalog command works too and I see the following message on the terminal

Build: 3.3 voltdb-3.3-0-gec0df82 Community Edition
Connecting to VoltDB cluster as the leader...
Host id of this node is: 0

I open another terminal session to run Sqlcmd and I get the message "Connection refused". I also tried running some builtin in examples (the voter app). The VoltDB server works again and I see the message posted above; but when I run the client, i see the following message

[root@v-ng-0096 voter]# ./run.sh client
--------------------------------------------------------------------------------
Command Line Configuration
--------------------------------------------------------------------------------

autotune = false
contestants = 6
displayinterval = 5
duration = 120
latencytarget = 6
maxvotes = 2
password =
ratelimit = 100000
servers = localhost:21212
statsfile =
user =
warmup = 5

--------------------------------------------------------------------------------
Setup & Initialization
--------------------------------------------------------------------------------

Connecting to VoltDB...
Connection failed - retrying in 1 second(s).
Connection failed - retrying in 2 second(s).
Connection failed - retrying in 4 second(s).
Connection failed - retrying in 8 second(s).


I have disabled the firewall to rule out firewall issues. Could anyone let me know what I am doing wrong?

Thanks,
Saju
vtkstef
Jun 13, 2013
Hi Saju,

can you please check if your server is listening to the socket that the client is attempting to connect to?

$ lsof -iTCP:21212 -sTCP:LISTEN

Does the output of the above command yield a process PID matching the output of the following command?

$ jps | grep VoltDB

Ciao
Stefano
sqlcmd connection refused
Shanky
Sep 19, 2013
HI sanju ,


Can you plz tell if both the PID's are scoming different then how to solve the problem.
Please reply soon


thanks in advance
Shanky
rmorgenstein
Sep 19, 2013
Your server did not come up entirely - not sure why. If it had come up, the final line from starting would be 'Server completed initialization.'. Take a look in the server logfile (probably in log/volt.log) and see where it is failing (or stuck). It might just be a port conflict. Feel free to post the logfile here and I'll take a look.

Ruth