Forum: Other

Post: VoltDB runs with JDK 8

VoltDB runs with JDK 8
christianh
Jun 17, 2013
Hi,

just in case somebody is interested: VoltDB runs perfectly fine on my Macbook Pro with JDK 8 (build 1.8.0-ea-b92). I didn't notice in the first place, that it actually was running on JDK 8 until i remembered, that i installed it for development of a new project. I checked and saw that VoltDB was using it.

Greetz
christian
jhugg
Jun 17, 2013
That's good to know. Out current list of supported platforms is basically just the stuff we test on, though VoltDB might run in different configs. We know it runs on a pretty broad set of Linux distros for example.

When JDK8 is officially out, we'll start getting it integrated into our test procedures.