Forum: Installation

Post: VoltDB crashes on startupunam

VoltDB crashes on startupunam
sureshg01
Aug 28, 2013
When i am starting VoltDB, its crashing , logs not helping in figuring out the cause, there is a old thread about same subject but no resolution.


/var/tmp/voltdb-3.4/examples/orders> voltdb create catalog catalog.jar host localhost deployment deployment.xml
Initializing VoltDB...

_ __ ____ ____ ____
| | / /___ / / /_/ __ \/ __ )
| | / / __ \/ / __/ / / / __ |
| |/ / /_/ / / /_/ /_/ / /_/ /
|___/\____/_/\__/_____/_____/

--------------------------------

Build: 3.4 voltdb-3.4-0-g87c6e44 Community Edition
Connecting to VoltDB cluster as the leader...
Host id of this node is: 0
#
# A fatal error has been detected by the Java Runtime Environment:
#
# SIGFPE (0x8) at pc=0x00002b252188768f, pid=30511, tid=1115707712
#
# JRE version: 7.0_13-b20
# Java VM: Java HotSpot(TM) 64-Bit Server VM (23.7-b01 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C [ld-linux-x86-64.so.2+0x868f] do_lookup_x+0xcf
#
# Core dump written. Default location: /var/tmp/voltdb-3.4/examples/orders/core or core.30511
#
# An error report file with more information is saved as:
# /var/tmp/voltdb-3.4/examples/orders/hs_err_pid30511.log
#
# If you would like to submit a bug report, please visit:
# http://bugreport.sun.com/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#
Abort(coredump)
ptuat@nyl96a-5705:/var/tmp/voltdb-3.4/examples/orders> uname -a
Linux nyl96a-5705 2.6.16.60-0.69.1-smp #1 SMP Fri Sep 17 17:07:54 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux
ptuat@nyl96a-5705:/var/tmp/voltdb-3.4/examples/orders>

-----
From volt.log

2013-08-28 18:32:27,694 INFO [main] CONSOLE: Initializing VoltDB...

_ __ ____ ____ ____
| | / /___ / / /_/ __ \/ __ )
| | / / __ \/ / __/ / / / __ |
| |/ / /_/ / / /_/ /_/ / /_/ /
|___/\____/_/\__/_____/_____/

--------------------------------

2013-08-28 18:32:27,711 INFO [main] CONSOLE: Build: 3.4 voltdb-3.4-0-g87c6e44 Community Edition
2013-08-28 18:32:27,718 INFO [main] NETWORK: Default network thread count: 4
2013-08-28 18:32:27,750 INFO [main] HOST: Beginning inter-node communication on port 3021.
2013-08-28 18:32:27,750 INFO [main] HOST: Attempting to bind to leader ip localhost/127.0.0.1:3021
2013-08-28 18:32:27,753 INFO [main] CONSOLE: Connecting to VoltDB cluster as the leader...
2013-08-28 18:32:27,786 INFO [main] ZK-SERVER: binding to port /127.0.0.1:2181
2013-08-28 18:32:27,797 INFO [main] ZK-SERVER: Created server with tickTime 3000 minSessionTimeout 6000 maxSessionTimeout 60000
2013-08-28 18:32:27,845 INFO [main] ZK-SERVER: Initiating client connection, connectString=127.0.0.1:2181 sessionTimeout=2000 watcher=org.voltcore.zk.ZKUtil$1@21a0769d
2013-08-28 18:32:27,851 INFO [main-SendThread()] ZK-CLIENT: Opening socket connection to server /127.0.0.1:2181
2013-08-28 18:32:27,855 INFO [main-SendThread(localhost:2181)] ZK-CLIENT: Socket connection established to localhost/127.0.0.1:2181, initiating session
2013-08-28 18:32:27,855 INFO [NIOServerCxn.Factory:/127.0.0.1:2181] ZK-SERVER: Accepted socket connection from /127.0.0.1:37491
2013-08-28 18:32:27,860 INFO [NIOServerCxn.Factory:/127.0.0.1:2181] ZK-SERVER: Client attempting to establish new session at /127.0.0.1:37491
2013-08-28 18:32:27,885 INFO [ZooKeeperServer] ZK-SERVER: Established session 0x14c9c67aea800000 with negotiated timeout 6000 for client /127.0.0.1:37491
2013-08-28 18:32:27,885 INFO [main-SendThread(localhost:2181)] ZK-CLIENT: Session establishment complete on server localhost/127.0.0.1:2181, sessionid = 0x14c9c67aea800000,
negotiated timeout = 6000
2013-08-28 18:32:27,968 INFO [Socket Joiner] HOST: Attempting to bind to internal ip 0.0.0.0/0.0.0.0:3021
2013-08-28 18:32:28,008 INFO [main] HOST: Host id of this node is: 0
2013-08-28 18:32:28,008 INFO [main] CONSOLE: Host id of this node is: 0
2013-08-28 18:32:28,035 INFO [main] HOST: URL of deployment info: deployment.xml
2013-08-28 18:32:28,349 INFO [main] HOST: Dead host timeout set to 10000 milliseconds
2013-08-28 18:32:29,113 INFO [main] EXPORT: System is not using any export functionality.
2013-08-28 18:32:29,220 INFO [Iv2ExecutionSite: 0:0] HOST: Loading native VoltDB code (voltdb-3.4). A confirmation message will follow if the loading is successful.
volt.log lines 1-93/93 (END)
jpiekos
Sep 27, 2013
Perhaps upgrade your Java version. It could be this JVM bug? http://bugs.sun.com/view_bug.do?bug_id=6968646

John