Forum: Installation

Post: Can't install voltdb 4.0.2 on redhat, pb with java version

Can't install voltdb 4.0.2 on redhat, pb with java version
luky55
Jan 31, 2014
Hello,

I am just starting with voltdb, trying to install it on Redhat 6.3.
I installed jdk 1.7 from Oracle site, but voltdb still refuses to install:

rpm -ivh voltdb-4.0.2-1.x86_64.rpm
error: Failed dependencies:
java >= 1:1.7.0 is needed by voltdb-4.0.2-1.x86_64

Currently, I have:
rpm -qa | grep jdk
java-1.6.0-openjdk-devel-1.6.0.0-1.50.1.11.5.el6_3.x86_64
java-1.7.0-openjdk-devel-1.7.0.9-2.3.4.1.el6_3.x86_64
java-1.6.0-openjdk-1.6.0.0-1.50.1.11.5.el6_3.x86_64
java-1.7.0-openjdk-1.7.0.9-2.3.4.1.el6_3.x86_64
jdk-1.7.0_51-fcs.x86_64


Thanks for helping
prosegay
Jan 31, 2014
you should install using the command:

sudo yum localinstall voltdb-4.0.2-1.x86_64.rpm

then it will find the dependency for java.
Still no No luck
luky55
Feb 3, 2014
you should install using the command:

sudo yum localinstall voltdb-4.0.2-1.x86_64.rpm

then it will find the dependency for java.


Hi,
Thanks for your reply, that did not work either, still same problem, it seems to be a tricky problem (at least for my knowledge) of java dependency.

Finally I had to do " rpm -ivh --force --nodeps voltdb-4.0.2-1.x86_64.rpm" to make it work.
prosegay
Feb 3, 2014
Please post the output from the command we suggested if you can.

Thanks.
prosegay
Feb 3, 2014
please post the contents of /etc/redhat-release and /etc/lsb-release if it exists.

Thanks.