Forum: Building VoltDB Applications

Post: RMI error while starting VoltDB

RMI error while starting VoltDB
interntest
Apr 28, 2015
What might be the possible reason for the following error on issuing the following command

voltdb create Catalog.jar

Can not resolve RMI server hostname while starting RMI server. JMX will be disabled and management tools may not function

Using VoltDB-5.1.2 on CentOS 6.6
vtkstef
Apr 28, 2015
Hi,

try


$ VOLTDB_OPTS="-Djava.rmi.server.hostname=your-host-name-here-or-ip" voltdb create Catalog.jar


Ciao
Stefano
vtkstef
Apr 28, 2015
or if you don't care about JMX the following will do too

$ VOLTDB_OPTS="-DDISABLE_JMX=true" voltdb create Catalog.jar


Ciao
Stefano
interntest
Apr 28, 2015
Thanks Stefano.

That worked smoothly :)
msurener
Jan 25, 2016
Hi Stefano. This command is not working for me .. i have installed VoltDB on Red Hat Enterprise Linux Server release 6.2 (Santiago) and have used the above command to start, but still getting the same error.

"ERROR: Can not resolve RMI server hostname while staring RMI server. JMX will be disabled and management tools may not function."

Thanks,
Suri
pzhao
Jan 25, 2016
msurener,
You can run VoltDB with this message. There should be no impact on performance due to this message.
You can disable JMX port with the syntax below:
VOLTDB_OPTS="DISABLE_JMX=true" voltdb create -H <hostname>
Alternatively, you can provide it a different port:
VOLTDB_OPTS="-Dvolt.rmi.agent.port=10020" voltdb create -H <hostname>
Peter Zhao