Results 1 to 2 of 2

Thread: community edition error

  1. #1
    New Member
    Join Date
    Mar 2014
    Posts
    3

    community edition error

    Hello,
    i have downloaded and installed the Enterprise Edition.
    i have used the:
    http://voltdb.com/download/enterprise-download/
    and there selected the rpm distribution:
    http://voltdb.com/downloads/loader.p...LinuxRpmServer
    however when running the voter example i am getting the Community Edition notification as you can see bellow, i am expecting to run the enterprise edition trial period. please advise what i am doing wrong:
    $ ./run.sh
    Starting the VoltDB server.
    To perform this action manually, use the command line:

    /usr/bin/voltdb create -d deployment.xml -l /usr/lib/voltdb/license.xml -H localhost voter.jar

    Initializing VoltDB...

    _ __ ____ ____ ____
    | | / /___ / / /_/ __ \/ __ )
    | | / / __ \/ / __/ / / / __ |
    | |/ / /_/ / / /_/ /_/ / /_/ /
    |___/\____/_/\__/_____/_____/

    --------------------------------

    Build: 4.0.2.3 voltdb-4.0.2.3-0-ge2f2df4-local Community Edition
    Connecting to VoltDB cluster as the leader...
    Host id of this node is: 0
    ERROR: Snapshots are not supported in the community edition of VoltDB.
    FATAL: This process will exit. Please run VoltDB with a deployment file compatible with the community edition.
    VoltDB has encountered an unrecoverable error and is exiting.
    The log may contain additional information.

  2. #2
    New Member
    Join Date
    Feb 2013
    Posts
    10
    Hi Boris,

    I just checked with our support group and inadvertently the Community Edition had been made available for download. It is fixed now. If you re-download, you will get the Enterprise Edition RPM. Please let me know if this helped you.

    Best regards
    Dheeraj

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •