Results 1 to 4 of 4

Thread: Sqlcmd says connection refused when trying to test Helloworld sample

  1. #1
    New Member
    Join Date
    Jun 2013
    Posts
    1

    Sqlcmd says connection refused when trying to test Helloworld sample

    Hi,

    I have installed VoltDB on a RHEL VM and was following the instructions given in the "Getting started guide". The compilation of helloworld.jar works fine. The create catalog command works too and I see the following message on the terminal

    Build: 3.3 voltdb-3.3-0-gec0df82 Community Edition
    Connecting to VoltDB cluster as the leader...
    Host id of this node is: 0

    I open another terminal session to run Sqlcmd and I get the message "Connection refused". I also tried running some builtin in examples (the voter app). The VoltDB server works again and I see the message posted above; but when I run the client, i see the following message

    [root@v-ng-0096 voter]# ./run.sh client
    --------------------------------------------------------------------------------
    Command Line Configuration
    --------------------------------------------------------------------------------

    autotune = false
    contestants = 6
    displayinterval = 5
    duration = 120
    latencytarget = 6
    maxvotes = 2
    password =
    ratelimit = 100000
    servers = localhost:21212
    statsfile =
    user =
    warmup = 5

    --------------------------------------------------------------------------------
    Setup & Initialization
    --------------------------------------------------------------------------------

    Connecting to VoltDB...
    Connection failed - retrying in 1 second(s).
    Connection failed - retrying in 2 second(s).
    Connection failed - retrying in 4 second(s).
    Connection failed - retrying in 8 second(s).


    I have disabled the firewall to rule out firewall issues. Could anyone let me know what I am doing wrong?

    Thanks,
    Saju

  2. #2
    Super Moderator
    Join Date
    Dec 2012
    Posts
    16
    Hi Saju,

    can you please check if your server is listening to the socket that the client is attempting to connect to?

    $ lsof -iTCP:21212 -sTCP:LISTEN

    Does the output of the above command yield a process PID matching the output of the following command?

    $ jps | grep VoltDB

    Ciao
    Stefano

  3. #3
    New Member
    Join Date
    Jul 2013
    Posts
    19

    sqlcmd connection refused

    HI sanju ,


    Can you plz tell if both the PID's are scoming different then how to solve the problem.
    Please reply soon


    thanks in advance
    Shanky

  4. #4
    Your server did not come up entirely - not sure why. If it had come up, the final line from starting would be 'Server completed initialization.'. Take a look in the server logfile (probably in log/volt.log) and see where it is failing (or stuck). It might just be a port conflict. Feel free to post the logfile here and I'll take a look.

    Ruth

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •